Running SwiftComp from a custom made file

  1. Alberto Fernandez

    Based on swiftcomp documentation I have created a msh.ech that I think is correct. I’d like to test if that is the case, but I see no way of running swiftcomp without doing it from the gmsh4SC user interface. Is there any way to carry out this work-flow in cdmhub?

  2. Wenbin Yu

    You can use the import function of the gmsh GUI. Or require a local copy of SwiftComp. -------- Original message -------- From: "Alberto Fernandez @ cdmHUB - The Composites HUB" <> Date: 9/27/17 09:15 (GMT-05:00) ---- Emailed forum response from
  3. Alberto Fernandez

    Thanks for the quick response. I've tried that, but nothing seems to happen. I tried running anyhow but I don't get an output. Is there any logs that I can check to see if I'm making an error?

  4. Xin Liu

    Sorry for my late reply. What is the SC input file you are using? The correct input file should ".sc" file not "msh.ech" file. I just test the Gmsh4SC GUI on the cdmhub, it can import .sc file and run SwiftComp without any problems. Note that if you are running the MSG beam model, you should directly click Homogenization->Beam model after importing .sc file. Please let me know if you have any other questions.

  5. Alberto Fernandez

    That was my mistake. I had created a .msh.ech file because that's what I saw comming out of the GUI.

    I'm trying to run it as you mentioned and I've run in another error. Is there a way to write comment lines in the file (just the comment), or the comment has to come after a readable line like it the examples? I had plenty of comments (similar to the msh.ech) and I'm in my way cleanning them up. Let see if with that I wrote the file correctly.

    Also, there is an issue with having spaces in the path when running in windows 7. It's not a big deal, but I thought I let you know in case it was not by design.

  6. Xin Liu

    It seems you can only add comments after a readable line. Thanks for your suggestions. We may modify the codes later so that the comments can be added in a new line. 

    Thanks a lot for pointing out the spaces of the path in windows system issue, I have tried to resolve this issue several times, but I couldn't find a robust way to fix that. Currently, for windows system, the easiest way is to add SwiftComp.exe into the system path.

  7. Alberto Fernandez

    As a dual system user I know solving those issues is a pain. So that you know, the problem is both with the path to the executable as well as the data file (.sc) when calling it from GUI. From the command line it is possible to put the path to the data file in quotes ("")