Close

Forum

trouble with a second web with ANSYS-VABS GUI

  1. Francois Molette

    Hello,

     

    I can build a correct model with the outer skin and the Leading Edge web. When I try to build the same profile, but with an additional web, I have the following error message:

    " I/O error: read layer type and \theta_1 for each element "

    It is for sure related to the connections of the parts, but I can't find where the problem is.

    Any help would be very welcome. At the end, I also have 3 isotropic areas to add, but I need first  to have a correct model without.

     

    In Attachment, I put the foolowing files:

    - Model_definition.txt, in which the different parameters used into ANSYS-VABS GUI

    - A Macro to define materials, ELBIT_Material

    - Airfoil  and Layout Layer files

    - ANSYS Database for both models before meshing

    - VABS Check files for the 2 webs model

    Thanks in advance, regards,

    Franocis

     

     

     

     

     

    Reply Report abuse

    Replying to Francois Molette

    1. Francois Molette

      I also tried with only Trailing edge web, and I have the same issue. The issue is probably here

      Reply Report abuse

      Replying to Francois Molette

    2. Fang Jiang

      When did the error " I/O error: read layer type and \theta_1 for each element " occur?

      Thanks!

      Fang

      Reply Report abuse

      Replying to Fang Jiang

    3. Fang Jiang

      I cannot check your odb file because the version installed on the group server is too low. Can you save your odb file to a lower version of ANSYS (say 15.0)?

      Reply Report abuse

      Replying to Fang Jiang

    4. Fang Jiang

      Hi Francois,

      Could you please also send me the VABS input file which gives the error " I/O error: read layer type and \theta_1 for each element "?

      Fang

      Reply Report abuse

      Replying to Fang Jiang

    5. Francois Molette

      it is already in attached document. it is the "2webs_input.dat" file

      thnaks

      Reply Report abuse

      Replying to Francois Molette

    6. Francois Molette

      please find in attachment the file without mesh in version 15:0

      Reply Report abuse

      Replying to Francois Molette

    7. Francois Molette

      in this database with only one web, it working without any problem.

      Reply Report abuse

      Replying to Francois Molette

    8. Fang Jiang

      Hello Francois,

      In the file "2webs_input.dat", the block of "Element_ID   Layer_ID   theta_1" does not contain the same amount of elements as identified by the 4th line of the input file. This problem is usually caused when we cut the segments into layer-wise areas. Mainly several elements with ID smaller than 15052 are missed from that block.

      Since the .db file you attached does not contain the mesh, I cannot identify which segment those missing elements belong to. So, you may want to check this and see if these element are located in the webs or the segment that the webs are connected to. If yes, you may want to rebuild your model and let the two web connect to two segments individually, respectively. In addition, you may also want to dense the small splines in the segments connecting the webs and the webs as well, so that these segment still have enough small lines on the inner boundary of the segments to let the program identify the area number, line number, element number, and material ID in these segments.

      Please let us know if it works or not. Thanks a lot!

      Fang

      Reply Report abuse

      Replying to Fang Jiang

    9. Fang Jiang

      Hello Francois,

      If the area where the elements are missed can be located, it is possible to manually fix the problem. In the background of the GUI, each area is mapped to the baseline of the of segment (this mapping results in the theta_1) and mapped to the layer ID by specific variables during the cutting. These variables are stored in ANSYS and fetched when the GUI is writing out the VABS input file. If you can find the definitions of these variables in the corresponding .mac file, you can manually fix/define them in the ANSYS db file. 

      Best Regards,

      Fang

      Reply Report abuse

      Replying to Fang Jiang