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1.0 GENERAL INFORMATION 
 

Based on the recently invented Mechanics of Structure Genome (MSG), SwiftComp™ provides 

an efficient and accurate approach for modeling composite materials and structures. It can be 

used either independently as a tool for virtual testing of composites or as a plugin to power 

conventional FEA codes with high-fidelity multiscale modeling for composites. SwiftComp™ 

implements a true multiscale theory which assures the best models at a given level of efficiency 

to capture both anisotropy and heterogeneity of composite constituents at the microscopic scale. 

SwiftComp™ enables engineers to model composites as a black aluminum, capturing details as 

needed and affordable. This saves orders of magnitude in computing time and resources without 

sacrificing accuracy, while enabling engineers to tackle complex problems effectively.  

 

SwiftComp™ can be used a standalone code or as a plugin for other commercial codes. To 

facilitate the use of SwiftComp™, a simple graphic user interface (GUI) based on Gmsh, called 

Gmsh4SC is developed. This manual focuses on explaining how to use Gmsh4SC.  

1.1 Installation and Get Started 
 

SwiftComp™ is available in the cloud through cdmHUB.org. You can simply login 

cdmHUB.org and launch SwiftComp Standard at https://cdmhub.org/resources/scstandard. If you 

prefer to run SwiftComp™ on your local machine, you need to unzip the distribution package 

into a folder of your own choice. Then you can either double click the executable file 

Gmsh4SC.exe (Gmsh4SC on Linux) or start a command line window to launch Gmsh4SC. 

Launching from a command line window is recommended as it will gives you the opportunity to 

observe the running of the program in the background. In the command line, if you launch 

Gmsh4SC in a folder different from the folder where you have stored both Gmsh4SC and 

SwiftComp executables, you need to set the path to the folder where you stored the executables 

for the system to find the code.  

1.2 Gmsh4SC Overview 
 

The first level menu of Gmsh4SC composes of three major parts: Modules, SwiftComp, and 

Input control. 

 

Modules 

Material: Users can define isotropic, orthotropic or general anisotropic materials properties for 

thermoelastic and conduction. 

Geometry: Users can create their model through Common SG, which provides several common 

microstructures of composites. Or they can build their own model by elementary entities which 

contain all basic geometry elements (e.g. point, line, surface, and volume). The last function in 

this part is to assign defined materials properties to corresponding regions in the model. 

https://cdmhub.org/resources/scstandard
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Mesh: Generate mesh according to the geometry of model, and user can choose different mesh 

algorithms to meet their needs. 

 

SwiftComp 

Homogenization: Users can invoke SwiftComp™ to compute the effect properties for different 

structural models (beam, plate/shell or 3D solid). 

Dehomogenization: With providing the global behavior, users can invoke SwiftComp™ to 

compute the local fields including displacements, stresses and strains, and contour plots will be 

automatically generated after calculation is completed. 

 

CalculiX 

Write INP file: This function takes the advantage of the original gmsh function to generate 

ABAQUS INP file, and mesh generation is modified to avoid possible issues for CalculiX solver 

CCX. Therefore, users can use this function to generate INP files with the original format from 

gmsh.  

 

Import structural properties: This function write the constitutive relation calculated from 

SwiftComp, and rearrange element sets to the corresponding constitutive relations. Also, this 

function will rewrite the whole input file to fit the new functions added in CalculiX solver CCX.  

 

Define step: This function will pop out the input file generated by “import structural properties”, 

and users need to input the boundary conditions and loading conditions manually. The boundary 

condition has the same format as ABAQUS INP file as well as the point loading. The definition 

of distributed load has been changed, which will be introduced later. 

 

Run: This function invokes the CalculiX solver CCX to perform FEA of structures. 

 

Results: This function will open the results file “filename_sc.dat” calculated by CCX, 

“filename_sc.dat” is generated by the new added functions in CCX, which will provide the 

results of global structural responses as shown below. And these results can be later used in 

dehomogenization analysis.  

 

Input control 

Edit file: A text file will open which contains all the information of the Modules part. Users can 

modify their model by change the input file according to the manual of Gmsh. 

Reload: After changing the input file, user needs to reload it to get the new model in GUI 

window. 
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1.3 Organization of the Manual 
 

Chapter One introduces the general information about Gmsh4SC and the functions in each part. 

 

Chapter Two describes how to use Common SG to quickly build the geometry of model and to 

set parameters to mesh the model. After running SwiftComp™, the results of homogenization 

and dehomogenization can be automatically shown in the GUI window. 

 

Chapter Three introduces how to create Square Pack Microstructure and Spherical Inclusions 

Microstructure, and a rectangular SG with two arbitrary inclusions by elementary entities 

functions provided by Gmsh, which requires users to create each geometry entity. These three 

examples should give users a good preparation to build user-defined models according to 

different analysis needs. 

 

Chapter Four introduces how to use FEA solver to read homogenization results and use the 

results to model macroscopic structural responses. The modeling framework using MSG is 

briefly introduced in this chapter, and an example is given to show step by step procedure of 

analyzing a beam-like structure.  
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2.0 CREATE COMMON MODEL 
 

Gmsh4SC provides a convenient way to create some common SG models. Engineers can easily 

create the geometry of these models, and invoke SwiftComp to perform homogenization and 

dehomogenization for different composites with typical microstructures.  

Currently, Gmsh4SC provides the following common SG models: 

Solid Model: square pack microstructure, square pack microstructure with interphase region, 

hexagonal pack microstructure, hexagonal pack microstructure with interphase region, spherical 

inclusion microstructure 

 

Plate/Shell Model: laminate 

 

Beam Model: box shape, I shape, rectangular, circle, pipe 

 

In this chapter, we will use some common SGs for different models (e.g. solid, laminate and 

beam) to illustrate how to use Gmsh4SC to perform homogenization and dehomogenization. For 

solid models, we will show 2D Square Pack Microstructure model and 3D Spherical Inclusions 

Microstructure. For laminates, we will show three different ways to generate 1D SG of laminates.  

 

First, Users need to create a new database with the name different from untitled.geo to build their 

model (see Fig. 2.1). Directly using of default database name (untitled.geo) is not allowed to 

avoid unintentional overwriting of valuable information. If you skipped this step, you will be 

reminded when you are carrying out the following steps.  

  

Fig. 2-1 

2.1 Square Pack Microstructure (2D) 

Define Materials 

Materials -> add.  

Choose materials type (e.g. Isotropic, Orthotropic, or Anisotropic). 
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In this example, assume fiber and matrix are both isotropic materials (Material 1: Young’s 

modulus E = 379.3GPa, Poisson’s ratio   = 0.1; Material 2: Young’s modulus E = 68.3GPa, 

Poisson’s ratio  = 0.3).  

1. Input Material ID number 1 and material properties, click Add. Then a message window 

will show up to tell user that material has been added (see Fig. 2-2 and Fig. 2-3).  

2. Change Material ID number to 2 and change material properties, click Add.   

3. After adding all materials, click Exit. 

 
Fig. 2-2 

 
Fig. 2-3 

 

Generate Common Model Geometry  

Geometry -> Common SG->2D SG->Other 2D SGs.  

Choose 2D SG, select type of models. In this case, select “Square Pack Microstructure”. 

Input volume fraction of fiber, and keep volume fraction of interphase zero if there is no 

interphase region in your model (see Fig. 2-4).  
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Select corresponding material ID to fiber and matrix, click Add (Fig. 2-5). The SG represented as 

a square with a circle at the end will be shown on the screen.  

 
Fig. 2-4 

 
Fig. 2-5 

 

Mesh 2D SG 

Mesh -> Mesh control. 

Set suitable parameters according to your model. The default element shape for 2D structure in 

Gmsh4SC is the triangular element. By selecting Recombine all triangular meshes, Gmsh4SC 

can generate quadrilateral elements. All the details about mesh control can be found in the Gmsh 

manual. In this example, we still use triangular elements and keep all default settings. 

Mesh -> Generate 2D mesh -> Generate. 
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After setting all the parameters, click Generate to create meshes (Fig. 2-6). If users want to get 

second-order (quadratic) elements, click button “Set order 2”. 

 
Fig. 2-6 

 

Homogenization 

SwiftComp -> Homogenization -> Solid Model 

Please read the manual of SwiftComp™ to see the meaning of each parameters.  

In this example, we consider our model is 3D structure, keep all default settings, click Save (Fig. 

2-7). 

Wait for preparing the input file of SwiftComp. Note that if the SG contains a large number of 

elements, it will take some time to prepare the input file.  

Click Run and wait for SwiftComp™ to finish the computation, the effective properties will pop 

up automatically (Fig. 2-8). In rare situations that error may occur, you can go to the command 

line window and it should report the error message of running SwiftComp™, which gives your 

indication what is wrong with the model.  
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Fig. 2-7 

 
Fig. 2-8 

 

Dehomogenization 

SwiftComp -> Dehomogenization -> Solid Model. 

Input the global behavior from the macroscopic structural analysis. Please refer to SwiftComp™ 

manual for meaning of the global behavior parameters. Click Save (Fig. 2-9). 

Click Run and wait for SwiftComp™ to finish the computation. The post-processing results will 

be automatically loaded, the default value is the magnitude of displacement as in (Fig. 2-10). 
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Contour plots are available for all local fields including three displacement components (U1, U2, 

U3) and its magnitude, six strain components (E11, E22, E33, 2E23, 2E13, 2E12) and six stress 

components (S11, S22, S33, S23, S13, S12).  

 
Fig. 2-9 

 
Fig. 2-10 
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2.2 Spherical Inclusions Microstructure (3D) 

Define Materials 

This step is the same as defining materials for 2D common SG model in the previous section. 

Choose materials type (e.g. Isotropic, Orthotropic or Anisotropic). In this example, we assume 

that both fiber and matrix are isotropic. Select MAT1 and MAT2, click add. (Fig. 2-11). 

 
Fig. 2-11 

 

Generate Common Model Geometry  

Geometry -> Common SG->3D SG.   

Choose 3D SG and input all the parameters according to your model, click Add (Fig. 2-12). 

 
Fig. 2-12 
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Mesh 3D SG 

Mesh -> Mesh control. 

User can set different mesh parameters by Mesh control. In this example, we keep all default 

settings for this model (Fig. 2-13). 

 
Fig. 2-13 

 

Mesh -> Generate 3D mesh -> Generate.  

User can also set second order element after the mesh generated (Fig. 2-14). 

 
Fig. 2-14 
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Homogenization 

SwiftComp -> Homogenization->Solid Model.  

Please read the manual of SwiftComp to see the meaning of each parameters. Input the 

parameters for your model (Fig. 2-15).  

Wait for preparing the input file of SwiftComp. Note that if the SG contains a large number of 

elements, it will take some time to prepare the input file.  

Click Run and wait for SwiftComp to finish the computation, the effective properties will pop up 

automatically (Fig. 2-16).  

 
Fig. 2-15 

 
Fig. 2-16 

Dehomogenization 
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SwiftComp -> Dehomogenization -> Solid Model. 

Input the global behavior from the macroscopic structural analysis. Click Save, then click Run 

The post-processing results will be automatically loaded, the default value is the magnitude of 

displacement as in Fig. 2-17. User can visualize all the other local fields by simply selecting the 

needed component and deselecting all other components.  

 
 

Fig. 2-17 

2.3 Laminates (1D) 

Define Materials 

Materials -> add.  

Choose materials type which could be isotropic, orthotropic, or general anisotropic, although we 

usually use orthotropic materials to define each lamina. We assume the following two different 

lamina properties: 

MAT-1:  E1 = 250GPa, E2 = 50GPa, E3 = 50GPa  

  G1 = 5GPa, G2 = 2GPa, G3 = 2GPa 

   12 = 0.25,  13 = 0.25,  23 = 0.25    

MAT-2:  E1 = 200GPa, E2 = 20GPa, E3 = 20GPa  

  G1 = 5GPa, G2 = 2GPa, G3 = 2GPa 

   12 = 0.3,  13 = 0.3,  23 = 0.3   

Then we will use three different ways to create 1D SG for different laminates users defined.  

 

Generate Common Model Geometry  
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Geometry -> Common SG-> 1D SG. 

Choose Fast generate function as shown in Fig. 2-18, then a new window will pop out. This 

function will provide a fast way to generate laminates. Users need to first choose if the plies are 

even or odd. Then, users can use simple notation to define ply sequence from the bottom to the 

top. For example, the notation [0/-45/60]2s means the following sequence [0/-45/60/0/-

45/60/60/-45/0/60/-45/0]. The number after bracket means the repeating times and “s” means 

symmetry. Choose material propertie s in the pull down menu, and input the above sequence and 

assign thickness for each ply (Fig. 2-19). 

  
Fig. 2-18 

 

 
Fig. 2-19 

 

After inputting all the parameters, click ‘Add’. The 1D SG for laminates has been created as 

shown in Fig. 2-20. Note that this module only deal with constant layer thickness and single 
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material property. As shown in Fig. 2-20, layers with different fiber orientation have been shown 

by different colors. 
 

 
Fig. 2-20 

 

Geometry -> Common SG-> 1D SG. 

If users want to create laminates with different layer thickness and material property, advanced 

module in laminate function can serve this purpose. Click Advanced, a new window pop out as 

shown in Fig. 2-21. Recall that we have defined two different materials properties. Input 

parameters as shown in Fig. 2-21. The 1D SG has been created as shown in Fig. 2-22. 

 
Fig. 2-21 
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Fig. 2-22 

Geometry -> Common SG-> Plate(Shell) Model. 

In addition, Laminate function also provides import file module to let users upload their own data 

file. This module can hand laminates with complex ply sequence. Click “import” in the laminate 

function, a new window will pop out. Users can choose the file which contains laminates data. 

(Fig. 2-23) 

 
Fig. 2-23 

The data file should follow some formats as shown in Fig. 2-24. Users need to provide the 

number of lamina, then the data of thickness, fiber orientation and material id. The data arranged 

follows bottom to top rule, which means that the first line defines the bottom layer of laminate. 
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Fig. 2-24 

Homogenization 

SwiftComp -> Homogenization.  

For laminates, the mesh has been generated right after defining laminate. Users can directly go to 

Homogenization function to get the properties of laminate. We will use the model generated by 

fast generate to show the results of Homogenization and Dehomogenization. Click Plate(Shell) 

Model in Homogenization function, keep default parameters and click save, and run (Fig. 2-25). 

Then the effective properties will pop up automatically (Fig. 2-26). 

 

 
Fig. 2-25 
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Fig. 2-26 

Dehomogenization 

SwiftComp -> Dehomogenization -> Plate(Shell) Model. 

Input the global behavior from the plate analysis. Click Save, then click Run. The post-

processing results will be automatically loaded, the default value is the magnitude of 

displacement as in Fig. 2-27. User can visualize all the other local fields by simply selecting the 

needed component and deselecting all other components.  

 

Fig. 2-27 
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2.4 Beam (2D) 

Gmsh4SC provides various types of beam section (Rectangular, I, Box, Circle and Pipe). For 

isotropic material, users can simply define the geometry parameters to create beam cross section. 

For composites beam, users can use “Laminate module” to create composites beam section. Then 

users can use SwiftComp to calculate effective properties (homogenization) and local 

displacements, stresses, and strains (dehomogenization). Next, we will use rectangular beam to 

show how to create isotropic and composites beam section. At last, we will show how to use 

“Laminate module” to create I beam section. 

 

2.4.1 Rectangular Beam (2D) 

Define Materials 

Materials -> add.  

Choose materials type, and we usually use orthotropic materials to define each lamina. E1 = 

250GPa, E2 = 50GPa, E3 = 50GPa, G1 = 5GPa, G2 = 2GPa, G3 = 2GPa,  12 = 0.25,  13 = 0.25, 

 23 = 0.25.  

Generate Common Model Geometry  

Geometry -> Common SG-> 2D SG->Beam section->Rectangular->Isotropic (Fig. 2-28). 

Input width 4 and height 5 of this rectangular beam and choose material-id 1. Then click ‘Add’. 

Then users can mesh the cross section and use SwiftComp to do homogenization and 

dehomogenization.  

 

 
Fig. 2-28 

 

 

Geometry -> Common SG-> 2D SG->Beam section ->Rectangular->Composites (Fig. 2-29) 

Input width 4. Then click ‘layup define ’. Then a window which is similar to the “Laminate 

module” pop up (Fig. 2-30). Here we use fast generate function. After clicking fast generate, 
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input laminate parameters, as shown in Fig. 2-31. Assume that the layup is [0/90/90/0]2 and the 

thickness of each ply is 1. Then click ‘Add’, and ‘Exit’. Click ‘Add’ in Beam Section window. 

Then the geometry of laminate beam has been created (Fig. 2-32). 

 
Fig. 2-29 

 

 

Fig. 2-30 
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Fig. 2-31 

 

 

 
Fig. 2-32 

 

 

Mesh 2D SG 

Mesh -> Generate 2D mesh -> Generate. 

After setting all the parameters, click Generate to create meshes (Fig. 2-33). 
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Fig. 2-33 

Homogenization 

SwiftComp -> Homogenization.  

Click Beam Model in Homogenization function, keep default parameters and click save, and run 

(Fig. 2-34). Then the effective properties will pop up automatically (Fig. 2-35). 

 

 
Fig. 2-34 
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Fig. 2-35 

Dehomogenization 

SwiftComp -> Dehomogenization -> Beam Model. 

Input the global behavior from the beam analysis, input 0.001 in e1 and leave other parameters as 

default values. Click Save, then click Run. The post-processing results will be automatically 

loaded, the default value is the magnitude of displacement as in Fig. 2-36. User can visualize all 

the other local fields by simply selecting the needed component and deselecting all other 

components.  

 

Fig. 2-36 
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2.4.2 I Beam (2D) 

 

Define Materials 

Materials -> add.  

Choose materials type, and we usually use orthotropic materials to define each lamina. E1 = 250 

GPa, E2 = 50 GPa, E3 = 50 GPa, G1 = 5 GPa, G2 = 2 GPa, G3 = 2 GPa,  12 = 0.25,  13 = 0.25, 

 23 = 0.25.  

 

Generate Common Model Geometry  

Geometry -> Common SG-> 2D SG->Beam section ->I ->Composites (Fig. 2-37) 

Input height(H) 20, width of bottom flange(b1) 10 and width of up flange(b1) 10. Then click 

‘layup define ’. Then a window which is similar to the “Laminate module” pop up. Here we use 

fast generate function. After clicking fast generate, input laminate parameters, as shown in Fig. 2-

38. Assume that the layup is [0/90/90/0]2 and the thickness of each ply is 0.5. Then click ‘Add’, 

and this step is used to create bottom flange of I beam. Repeat the above step to create up flange 

and web of I beam. After adding web, a message “I beam has been generated!” will show up. 

Click ‘Add’ in Beam Section window. Then the geometry of I beam has been created (Fig. 2-39). 

 

 
Fig. 2-37 
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Fig. 2-38 

 

 

Fig. 2-39 

 

Mesh 2D SG 

Mesh -> Generate 2D mesh -> Generate. 

After setting all the parameters, click Generate to create meshes (Fig. 2-40). 
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Fig. 2-40 

 

 

Homogenization 

SwiftComp -> Homogenization.  

Click Beam Model in Homogenization function, change coordinate system to material 

coordinate. And click save, and run (Fig. 2-41).  

 

 
Fig. 2-41 
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Dehomogenization 

SwiftComp -> Dehomogenization -> Beam Model. 

Input the global behavior from the beam analysis, input 0.001 in e11 and leave other parameters 

as default values. Click Save, then click Run. The post-processing results will be automatically 

loaded, the default value is the magnitude of displacement as in Fig. 2-42. User can visualize all 

the other local fields by simply selecting the needed component and deselecting all other 

components.  

 

Fig. 2-42 

Box beam is very similar to I beam, users can try this function to create box section. 
 

2.5 Summary 
 

Common SG function provides users a convenient way to quickly build the geometry of common 

SG, and easily specify materials and structures properties they want to test. Users can also test 

other common models if they are interested. 
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3.0 CREATE USER-DEFINED MODEL 
 

Although common SG function provides users a convenient way to build the geometry of the 

most common models, often users need to build their own models according to the 

microstructure they are analyzing. Without using the common SG function, this chapter will 

illustrate how to build the above two common models along with a rectangular SG with two 

arbitrary inclusions using the simple CAD capabilities provided by Gmsh.  

The only difference between user-defined model and common SG model is the generation 

geometry of model and assign material properties. The procedures of meshing and running 

SwiftComp are the same. So we will only focus on the geometry creation and materials 

assignment in this chapter. Since we are using the native CAD capabilities in Gmsh, users are 

encouraged to refer to the Gmsh manual for more detailed instructions on geometry creation and 

materials assignment.  

3.1 Square Pack Microstructure (2D) 

Generate User-defined Model Geometry 

Click Geometry -> Elementary entities -> Add -> Point.  

Input the coordinates of the model (-0.5,-0.5, 0), (0.5,-0.5, 0), (0.5, 0.5, 0) and (-0.5, 0.5, 0). 

These coordinates are used for defining the SG boundary.  

Input the coordinates of the model (0, 0, 0), (0, 0.3569, 0), (-0.3569, 0, 0), (0, -0.3569, 0) and 

(0.3569, 0, 0). These coordinates are used for defining the fiber boundary, and need to be 

calculated first according to the volume fraction of fiber. Exit Add point, and hit q (Fig. 3-1). 

 
Fig. 3-1 
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Click Geometry -> Elementary entities -> Add -> Straight line.  

Select starting point: Point 4 (-0.5, 0.5, 0) and then select end point: Point 1 (-0.5,-0.5, 0) now 

Line 1 {4 1} is created; note that direction of lines must be counterclockwise. Please note this 

is required for creating user-defined models. Then add Line 2 {1 2}, Line 3 {2 3}, Line 4 {3 

4}. After adding all straight lines, hit q (Fig. 3-2). 

 
Fig. 3-2 

 

 
Fig. 3-3 

 

Click Geometry -> Elementary entities -> Add -> Circle arc.  
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Select starting point: Point 9 {-0.3569, 0, 0}, select center point: Point 5 {0, 0, 0}, select end 

point: Point 7 {0, -0.3569, 0}, now Circle 5 {9 5 7} is created. Then repeat above steps to create 

Circle 6 {7 5 8}, Circle 7 {8 5 6} and Circle 8 {6 5 9} (Fig. 3-3 and Fig. 3-4). Note that all circle 

arcs must also be counterclockwise. 

 
Fig. 3-4 

 

Click Geometry -> Elementary entities -> Add -> Plane surface  

(This step is a preparation for materials assignment) 

Select surface boundary: Line 1, Line 2, Line 3 and Line 4, select the boundaries of the circle: 

Circle 5, Circle 6, Circle 7 and Circle 8, hit ‘e’ to end selection, then matrix domain has been 

created. Then select surface boundary Circle 5, Circle 6, Circle 7 and Circle 8, hit ‘e’ to end 

selection and ‘q’ to abort, then the fiber domain has been created (Fig. 3-5 and Fig. 3-6).  

 
Fig. 3-5 
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Fig. 3-6 

 

Assign Materials 

Click Geometry -> Assign material -> 2D SG  

Set Material ID number to be 1, select inner circular plane and hit ‘e’. Change Material ID 

number to be 2, select outer plane and hit ‘e’ and hit ‘q’. Now two planes are assigned with 

material 1 and material 2 respectively (Fig. 3-7). This step is not needed in the generation of 

common SG, because material IDs are assigned to corresponding regions when the common SG 

geometry is created. 

 
Fig. 3-7 
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Generate Periodic Nodes 

Periodicity -> 2D SG. 

Select the first corresponding periodic lines, in this case Line 1 and Line 3, and click ‘e’ (Fig. 3-

8). Use the same procedure to create second periodic boundary lines. 

 

 
Fig. 3-8 

 

 
Fig. 3-9 
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The rest procedures are the same as the previous chapter for generating common SG model: 

Mesh -> Mesh control 

Mesh -> Generate 2D mesh -> Generate, see Fig. 3-9. 

Mesh -> Set order 2 (Optional) 

SwiftComp -> Homogenization 

SwiftComp -> Dehomogenization 

 

 

3.2 Spherical Inclusions Microstructure (3D) 

Generate User-defined Model Geometry  

Click Geometry -> Elementary entities -> Add -> Point.  

Input the coordinates of the model (-0.5, -0.5, -0.5), (-0.5, 0.5, -0.5), (-0.5, 0.5, 0.5), (-0.5, -0.5, 

0.5). Users can open the menu -> Tools -> Options -> Geometry -> Visibility to turn on Point 

labels and Line labels. 

Choose Translate -> Duplicate point, input 1 in the X component and select all points on screen, 

hit ‘e’ to end selection and hit ‘q’ to abort (Fig. 3-10 and 3-11). 

 

 
Fig. 3-10 
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Fig. 3-11 

 

Click Geometry -> Elementary entities -> Add -> Straight line. 

Similarly as adding straight line in 2D model, create the Line 1 {6 7},  Line 2 {7 8},  Line 3 {8 

5}, Line 4 {5 6}, Line 5 {2 3}, Line 6 {3 4}, Line 7 {4 1}, Line 8 {1 2}, Line 9 {2 5}, Line 10 {8 

1}, Line 11 {7 4}, Line 12 {3 6}. See Fig. 3-12.  

 

 
Fig. 3-12 
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Click Geometry -> Elementary entities -> Add -> Plane surface. 

Select Line 1, Line 2, Line 3, Line 4, hit ‘e’. Then the corresponding plane surface is created and 

two cross dash lines showing at that surface (Fig. 3-13). Repeat above procedure to create other 

plane surfaces (Fig. 3-14).  

 
Fig. 3-13 

 

 

 
Fig. 3-14 
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Click Geometry -> Elementary entities -> Add -> Point. 

Input the coordinates needed for generating the inclusion (0, 0, 0), (-0.457, 0, 0), (0, 0.457, 0), (0, 

0, 0.457).  See Fig. 3-15. 

 
Fig. 3-15 

 

Click Geometry -> Elementary entities -> Add -> Circle arc. 

Select Point 11, Point 9 and Point 12 to create Circle 25. 

Select Point 12, Point 9 and Point 10 to create Circle 26. 

Select Point 10, Point 9 and Point 11 to create Circle 27. 

Note that the index of Circle is decided by the geometry entities which are related to the order of 

the geometry components user created, but the index is just used for illustrating how to create 

model and it is not important for the following steps (Fig. 3-16). 

 
Fig. 3-16 
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Click Geometry -> Elementary entities -> Add -> Ruled surface. 

Select Circle 25, Circle 26 and Circle 27, hit ‘e’ to create Ruled surface (Fig. 3-17). 

 
Fig. 3-17 

 

Click Geometry -> Elementary entities -> Rotate -> Duplicate surface. 

Select ruled surface just created, and input parameters as shown in Fig. 3-18 to duplicate a new 

ruled surface. 

Select new created surface and keep the parameters unchanged to create the next two surfaces 

(Fig. 3-19 and 3-20). Then, the up-half spherical has been created. 

 

 
Fig. 3-18 
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Fig. 3-19 

 

 
Fig. 3-20 

 

Change the parameters (Fig. 3-21) to create the other half particle. Note that the particle surface 

is made up by 8 ruled surfaces (Fig. 3-22). 
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Fig. 3-21 

 

 
Fig. 3-22 

 

Click Geometry -> Elementary entities -> Add -> Volume. 

Select particle surface and hit ‘e’ to create Volume 1. Select cubic matrix surface and then 

particle surface, hit ‘e’ to create Volume 2. See Fig. 3-23. 
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Fig. 3-23 

 

Assign Materials 

Click Geometry -> Assign material -> 3D SG 

Set Material ID number to be 1, select inner yellow ball and hit ‘e’. Change Material ID number 

to be 2, select inner yellow ball and hit ‘e’ and ‘q’, as shown in Fig. 29. Note that the two 

volumes we defined previously has overlapped at the center of geometry model. Here we need to 

change the database file (*.geo) to modify materials definition (Fig. 3-24). 

 
Fig. 3-24 

 

Click Input control -> Edit file 
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A text file will pop up to show the detailed information of the model you created and go to the 

last line. User can easily find that the Physical Volume 1 and Physical Volume 2 are 

corresponding to Material 1 and Material 2 we have defined. But Physical Volume 1 and 

Physical Volume 2 assign to the same Volume index, change the index according to your model.  

Save file and click Input control -> Reload (Fig. 3-25). 

Note that this problem only exists when the center of two volume is overlapped, so user can 

always simply use common SG functions to avoid this problem if they do not want to handle the 

input file. 

     

 
Fig. 3-25 

 

Generate Periodic Nodes 

Periodicity -> 3D SG. 

Select the periodic surfaces in one direction, Fig. 3-26(e.g. surface 14 and 24). Then select the 

corresponding lines in each surface. In this case, select Line 12 and Line 9, Line 6 and Line 8, 

Line 11 and Line 10, Line 1 and Line 3(Fig. 3-27). Click ‘e’ to create periodic boundary in z 

direction. Repeat the above steps to create periodic boundary in x, y direction.  

 
Fig. 3-26 
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Fig. 3.27 

The rest procedures are the same as in the previous chapter for generation of common SG model: 

Mesh -> Mesh control 

Mesh -> Generate 3D mesh -> Generate, see Fig. 3-28 

Mesh -> Set order 2 (Optional) 

SwiftComp -> Homogenization 

SwiftComp -> Dehomogenization 

 

 
Fig. 3-28 
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3.3 Arbitrary Shape Inclusions Microstructure (2D) 

One more user-defined model is shown here except for the two common models above, which is 

a rectangle SG with two arbitrary inclusions. Users can understand how to create complex shape 

in Gmsh4SC, and also know the capability of SwiftComp to calculate such models. Since this is 

not a common model in Gmsh4SC, all the steps needed for homogenization and 

dehomogenization will be provided below.  

Define material  

Materials -> Add.  

Choose materials type (e.g. Isotropic, Orthotropic or Anisotropic). 

In this example, assume that inclusions and matrix are both isotropic materials (Material 1: E = 

379.3GPa,   = 0.1; Material 2: E = 279.3GPa,   = 0.1; Material 3: E = 68.3GPa,   = 0.3).  

Material ID number 1 and material properties, click Add. Then a message window will show up 

to tell user that material has been added. Then change Material ID number to 2 and 3, and change 

material properties, click Add. After adding all materials, click Exit. 

Generate User-defined Model Geometry 

Click Geometry -> Elementary entities -> Add -> Point.  

Input the coordinates of four points (-0.5,-1, 0), (-0.5, 1, 0), (0.5, 1, 0) and (0.5, -1, 0). These 

coordinates are used for defining the SG boundary. 

Users can add points through the GUI window, just hit ‘e’ at the position where a node is needed. 

For convenience, the points are given here: (-0.2, 0.8, 0), (-0.3, 0.7, 0,), (-0.3, 0.4, 0), (-0.1, 0.6, 

0), (0, 0.8, 0), (0, 0, 0), (-0.1, 0, 0), (-0.2, -0.3, 0), (0.1, -0.5, 0), (0.1, -0.3, 0) and (0.2, -0.1, 0). 

Note that all these nodes are drawn arbitrarily in this model, and the coordinates are just read 

from the *.geo file (Fig. 3-29). 

 
Fig. 3-29 
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Click Geometry -> Elementary entities -> Add -> Straight line.  

Select starting point: Point 3 and then select end point: Point 2 now Line 1 {1 2} is created; note 

that direction of lines must be counterclockwise (Please note this is required for creating 

user-defined models). Then add Line 2 {3 2}, Line 3 {2 1}, Line 4 {4 3}. After adding all 

straight lines, hit q (Fig. 3-30). 

 
Fig. 3-30 

Click Geometry -> Elementary entities -> Add -> Spline.  

Select starting point: Select Point 9 and then select the following points: Point 5, Point 6, Point 7, 

Point 8, and Point 9. Then, the line loop for the first inclusion has been created (Fig. 3-31). 

Select starting point: Select Point 13 and then select the following points: Point 14, Point 15, 

Point 10, Point 11, Point 12 and Point 13. Then, the line loop for the second inclusion has been 

created (Fig. 3-32). Note that all the splines must also be counterclockwise. 

 
Fig. 3-31 
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Fig. 3-32 

 

Click Geometry -> Elementary entities -> Add -> Plane surface  

(This step is a preparation for materials assignment) 

Select surface boundary: Line 1, Line 2, Line 3 and Line 4, select the inclusion boundaries: line 

loops of inclusion 1 and inclusion 2, hit ‘e’ to end selection, then matrix domain has been 

created. Then select surface boundary of inclusion 1 and hit ‘e’ to end selection, select surface 

boundary of inclusion 2, hit ‘e’ to end selection and ‘q’ to abort, then two inclusion domains 

have been created (Fig. 3-33). 

 
Fig. 3-33 
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Assign Materials 

Click Geometry -> Assign material -> 2D SG  

Set Material ID number to be 1, select surface of inclusion 1 and hit ‘e’. Change Material ID 

number to be 2, select surface of inclusion 2 and hit ‘e’. Set Material ID number to be 3, select 

surface of matrix and hit ‘q’ (Fig. 3-34). 

 
Fig. 3-34 

Generate Periodic Nodes 

Periodicity ->2D SG. 

Select the first pair of corresponding periodic lines, in this case Line 2 and 4(Fig. 3-35), click ‘e’. 

Then repeat the above procedure to create second pair of periodic lines. 

 

Fig. 3-35 
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Fig. 3-36 

Mesh 2D SG 

Mesh -> Mesh control. 

Set suitable parameters according to your model. The default element shape for 2D structure in 

Gmsh4SC is triangular element. By selectig recombine all triangular meshes, Gmsh4SC can 

generate quadratic elements. Since we use triangular elements in previous examples, we use 

quadrilateral elements in this example. 

Mesh -> Generate 2D mesh -> Generate. 

After setting all the parameters, click Generate to create the mesh (Fig. 3-36). 

Homogenization 

SwiftComp -> Homogenization -> Solid Model 

Choose the structural model (e.g. Solid, beam and shell/plate) you are using for your macroscopic 

analysis. In this example, we consider our model is 3D structure, keep all default settings, click 

Save. 

 

Wait for preparing the input file of SwiftComp. Note that if the SG contains a large number of 

elements, it will take some time to prepare the input file.  

 

Click Run and wait for SwiftComp to finish the computation, the effective properties will pop up 

automatically (Fig. 3-37). 
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Fig. 3-37 

 

Dehomogenization 

SwiftComp -> Dehomogenization -> Solid Model. 

Input the global behavior from the macroscopic structural analysis. Click Save, then click Run. 

The post-processing results will be automatically loaded, the default value is the magnitude of 

displacement as in Fig. 3-38. User can visualize all the other local fields by simply selecting the 

needed component and deselecting all other components.  

 
Fig. 3-38 
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3.4 Summary 

Gmsh4SC provides geometry modules to create user-defined models according to analysis needs. 

In general, users need to complete the flowing steps to create the user-defined SG model: 

1. Define materials 

2. Create points 

3. Create lines 

4. Create surface plane 

5. Create volume (for 3D case) 

6. Assign materials properties 

7. Set mesh parameters 

8. Mesh 

9. Run SwiftComp 

 



User’s Manual      

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4.0 FEA SOLVER 

 

 

 

 

 

 

 

 

 

 

 



User’s Manual   Page 4-1   

 

4.0 FEA SOLVER 
 

In order to make Gmsh4SC has the capability to perform structural analysis, an open source finite 

element analysis (FEA) software CalculiX is connected to Gmsh4SC in the solver module. The 

new added solver module contains five parts: write INP file, import structural properties, define 

step, run and results. CalculiX uses a similar input format as ABAQUS, and it is a widely used 

finite element analysis (FEA) software in the mechanical and aerospace engineering community. 

After adding FEA solver capability, Gmsh4SC can be used to analyze structures without the help 

of other commercial FEA software. The modeling framework is briefly introduced next.   

 
Fig. 4-1 

 

4.1 Modeling framework 
 

The structural modeling performed by Gmsh4SC is based on the concept of Mechanics Structure 

Genome (MSG). For the detail information about MSG, readers can refer to the SCManual in the 

supporting documents. Currently the solver part only has the capability to perform beam-like 

structure analysis. The plate/shell and solid structures will be added shortly.  
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In general, there are four steps for structural modeling using MSG. First, the typical SG needs to 

be identified based on the heterogeneity of the original structure. Then, the second step is SG 

homogenization analysis, which has been detailed introduced in chapter two and three. The 

second step will give the first result, which is the constitutive relation of structural elements. For 

beam-like structures, it is the beam stiffness matrix. For plate/shell-like structures, it is A, B and 

D matrix, and for 3D solid structures, it is the general 6 by 6 material properties matrix. After we 

get the constitutive relation of structural elements, then we can carry out macroscopic structural 

analysis to get structural global responses, like displacements and strain. This work is done by 

the new added solver module. At last, we use the global responses as input parameters to carry 

out SG dehomogenization analysis to get local pointwise displacements/stresses/strains. 

 

4.2 Solver module 
 

After meshing the structure, we can move on to the Solver module to carry out structural 

analysis. 

 

Write INP file: This function takes the advantage of the original gmsh function to generate 

ABAQUS INP file, and mesh generation is modified to avoid possible issues for CalculiX solver 

CCX. Therefore, users can use this function to generate INP files with the original format from 

gmsh.  

 

Import structural properties: This function write the constitutive relation calculated from 

SwiftComp, and rearrange element sets to the corresponding constitutive relations. Also, this 

function will rewrite the whole input file to fit the new functions added in CalculiX solver CCX.  

 

Define step: This function will pop out the input file generated by “import structural properties”, 

and users need to input the boundary conditions and loading conditions manually. The boundary 

condition has the same format as ABAQUS INP file as well as the point loading. The definition 

of distributed load has been changed, which will be introduced later. 

 

Run: This function invokes the CalculiX solver CCX to perform FEA of structures. 

 

Results: This function will open the results file “filename_sc.dat” calculated by CCX, 

“filename_sc.dat” is generated by the new added functions in CCX, which will provide the 

results of global structural responses as shown below. And these results can be later used in 

dehomogenization analysis.  

 

Displacement (U1, U2, U3) in the beam at each node 

Node_number  U1  U2  U3 

…… 

 

Rotation (theta1, theta2, theta3) in the beam at each node 
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Node_number  theta1  theta2  theta3 

…… 

 

Strain (gamma11,k1,k2,k3) in the beam at gauss points 

Gauss_point_number  gamma11  k1  k2  k3 

…… 

 

Strain (gamma11,k1,k2,k3) in the beam at nodal points 

Gauss_point_number  gamma11  k1  k2  k3 

…… 

 

Stress resultants (F1,M1,M2,M3) in the beam at gauss points 

Gauss_point_number  F1  M1  M2  M3 

…… 

 

Stress resultants (F1,M1,M2,M3) in the beam at nodal points 

Gauss_point_number  F1  M1  M2  M3 

…… 

 

The detailed information of the results can be found in SCmanual in the support documents. Note 

that the gauss points are arranged element by element, which means gauss point 1 and 2 are in 

the element 1, and gauss point 3 and 4 are in the element 2 if two points gauss integration is used. 

 

4.3 New elements in CalculiX 
 

CalculiX includes many structural elements for 3D structures, and also it has quadratic 

formulations to deal with plane stress, plane strain and axi-symmetric problems. Although 

CalculiX can handle beam and plate problems, its beam and plate elements are expanded to be 

3D 20-noded brick elements with appropriate boundary conditions. This means CalculiX cannot 

take the advantage of structural constitutive relation of beam and plate structures, and it cannot 

deal with beam structures with complex cross section geometry. To overcome this limitation and 

take the advantage of constitutive information obtained from SwiftCompTM, new beam elements 

are developed and added into CCX. 

 

There are two new added beam element: NB11 and NB21. NB11 means the new added linear 

beam element using Euler-Bernoulli model. And NB21 means the new added linear beam 

element using Timoshenko model. “N” represents new element. “B” represents beam element. 

The first letter follow “B” means element type, which “1” means Euler-Bernoulli element and 

“2” means Timoshenko model. The second number means the order of element, which “1” 

means linear elements, and “2” means quadratic elements. 

 

The constitutive information is read by the added key word: *SCINPUT. There are three parts in 

this line: 
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*SCINPUT, ELSET=EALL, SCMODEL=B  

 

The first Part *SCINPUT indicts this is the new function which is used for reading constitutive 

information obtained from SwiftCompTM. Next is the element sets used to assign the constitutive 

relation to the elements. The third part is SCMODEl to indict different models used, which will 

be used later when the new 2D elements are ready. Now it is just using SCMODEL=B. The 

following are 4 by 4 beam stiffness matrix if using Euler-Bernoulli element or 6 by 6 beam 

stiffness matrix if using Timoshenko element.    

    

 

4.4 Define step 

 

Most functions in solver module are very straightforward. However, define step function needs 

users to input boundary condition and loading manually. The format for boundary condition and 

point loading is the same as ANAQUS input file, readers can refer to ABAQUS documents to see 

the detailed information. For example, the typical define step format is given below for the 

clamped beam with 2 nodes subjected to point force along z-direction acting at free end. 

…… 

*BOUNDARY 

1,1,6 

*STEP 

*STATIC 

*CLOAD 

2,3,-10 

*END STEP 

 

For the distributed load, the format is different from the original INP file. The key word for 

distributed load is “*DLOAD”, which is the same as standard format in INP file. The next line is: 

Element sets, Direction flag, Magnitude of the load   

 

Example: 

*DLOAD 

EALL,SCB3,1 

 

Which assigns a pressure loading with magnitude 1 points to the z-direction for element set 

“EALL”. And the direction flags are defined as: 

SCB1: uniform distributed load points to x-direction 

SCB2: uniform distributed load points to y-direction 

SCB3: uniform distributed load points to z-direction 

SCB4: uniform distributed moment points to x-direction 

SCB5: uniform distributed moment points to y-direction 

SCB6: uniform distributed moment points to z-direction 
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4.5 Example 
 

We will use a simple example to show how to use new added solver module to analyze a beam-

like structure. Suppose we have an 8-layer laminated beam as shown in Fig. 4-2. This beam is 

clamped at x = 0, and subjected to 10 KN point force in x-direction and -10 KN point force in z-

direction at x = 1. The laminate is made of eight layers, each layer is made of a continuous fiber 

reinforced composite. The fiber and matrix are assumed to be isotropic, and fiber volume faction 

is 40%. The homogenized unidirectional fiber reinforced lamina properties are given in Fig. 4-3.  

 

4.5.1 Homogenization analysis  

 

Create a new file named mat1.geo for this model. Using fast generation function, we get quickly 

build laminated beam section as shown in Fig. 4-4. Now the first step in Fig. 4-1 is achieved. 

After meshing the section and carry out homogenization analysis using SwiftComp molule, we 

obtained the 4 by 4 section stiffness matrix, which is stored in filename.msh.k file. This is the 

step 2 and the result 1 in Fig. 4.1. 

   

 
Fig. 4-2 

 
Fig. 4-3 (Units: MPa) 
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Fig. 4-4 

 

 

4.5.2 Macroscopic structural analysis  

 

The third step is macroscopic structural analysis. As we have the homogenization properties of 

this beam, the finite element model of this beam structure can be easily represented as a line with 

appropriate boundary condition. This step is accomplished using CalculiX module in Gmsh4SC, 

which will generate the input file for finite element solver CCX and pop up the results file 

contains global structural response like displacements, strain fields and resultant forces of beam. 

 

After homogenization analysis, the simplified structure should be built. In terms of beam-like 

structures, we use a line to represent the original structure. Gmsh4SC provides CAD functions to 

create the geometry of models.  

 

The constitutive relation should be assigned before meshing the structure as shown in Fig. 4-5. 

Assign structural properties -> Beam, then choose the part.  



4.0 FEA SOLVER 

 

User’s Manual   Page 4-7 

 

 
Fig. 4-5 

After selecting the part, press ‘e’ to confirm your selection as shown in Fig. 4-6, and press q to 

finish selection and open the browser to choose constitutive result file generated by 

homogenization analysis as shown in Fig. 4-7. 

 
Fig. 4-6 
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Fig. 4-7 

 

After assigning structural properties, we go to mesh function to create 1D mesh as shown in Fig. 

4-8. Then we are ready to use functions in CalculiX module to carry our macroscopic structural 

analysis. Click Write INP file, then click import structural properties. Users don’t need to do any 

other work for these two steps. Then click Define step to pop out input file for CalculiX solver 

CCX, and input the following key words for the boundary conditions and loading in this 

example: 

…… 

*BOUNDARY 

1,1,6 

*STEP 

*STATIC 

*CLOAD 

2,1,10000 

2,3,-10000 

*END STEP 

The input file for users to input manually is shown in Fig. 4-9. 
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Fig. 4-8 

 
Fig. 4-9 

Save the input file, and click run. After the job finished, click Results to show the structural 

global responses (global displacements and global strains).  
 

4.5.3 Dehomogenization analysis  

 

Users can choose the cross section they are interested, and input the corresponding parameters 

which can directly obtained from the results file (filename_sc.dat). The input window and how to 

input parameters are shown in the Chapter 2 and Chapter 3. For this example, the 

dehomogenization results are shown in Fig. 4-10. 
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Fig. 4-10. 

 

4.6 Summary 
 

This chapter briefly introduces the FEA solver module, which makes Gmsh4SC have the 

capability to carry out the whole procedure of structural analysis. Gmsh4SC is built based on 

MSG, which provides an alternative approach to model composite structures. More examples 

will be found in the tutorials in support documents. 

 

 


