Close

Forum

Stress/Strain Recovery and Visualization

  1. Dana Frye

    Hi All,

    I am attempting to utilize the functionality to perform the dehomogenization and recover and visualize local 3D strains and stresses at every point of the cross section. Before I tried incorporating the specifications for recovery into my model (as per https://wenbinyugroup.github.io/ivabs/prevabs/guide/pre_recover.html), I first just tried to perform the recovery and visualization on the example model ex_airfoil_r packaged with the preVABS release.

    I copied the input files into a new directory, and first ran homogenization via "prevabs -i mh104.xml -h -e -v". This was successful. Then I tried to run the recovery via ""prevabs -i mh104.xml -d -e -v". This is where I'm running into issues. The gmsh plots appear empty (see 2nd attached figure), and warnings are issued such as "Unable to find the file: mh104.sg.EN" (see 1st attached figure). 

    I am using preVABS v1.4.2 and VABS v4.0. 

    I was hoping to get some help with this. If I can't perform recovery of 3D stress/strain and plot with the unmodified example model, I have little hope for doing so with my own model. 

    Thanks, 

    Dana

    Airfoil (MH-104) Recover Warnings

    Reply Report abuse

    Replying to Dana Frye

    1. Dana Frye

      Other gmsh screenshot.

      recover-2.png

      Reply Report abuse

      Replying to Dana Frye

    2. Su Tian

      Hello Dana,

      Please use the attached file to replace the 'ex_airfoil_r' example. The only change is the input syntax for the load in the file 'mh104.xml'. The outdated example will be fixed in the next version.

      Reply Report abuse

      Replying to Su Tian

      1. Kevin Wang

        Hi Su,

        Can you run through stress recovery for the example and share your result?  For some reason every since 1.4, my results are getting scrambled for a portion of the elements.  Attached shows my tube test section as well as the mh104 example.  As you can see from the tube, a portion of it looks to be producing predictable results while the rest seem to be scrambled.

        MH104-example.png

        Report abuse

    3. Su Tian

      Hi Kevin,

      This is caused by the change of the stress/strain output format of VABS. I will quickly fix this in two days. Thank you for pointing out the issue.

      Reply Report abuse

      Replying to Su Tian

      1. Kevin Wang

        Thanks Su!

        Regarding running -fi for failure index/strength ratio, when I try to run the example for it, it says everything goes through fine, however there's no .fi file generated.  I've attached a screenshot of the run.

        Per the VABS manual, results should be stored in "input_file_name.fi" correct?

        nofifile.png

        Report abuse

      2. Dana Frye

        Hey Su, 

        Just checking in on the fix here. Do we need to download a new version of preVABS or VABS to take advantage of the fix?

        Thanks

        Report abuse

    4. Su Tian

      Kevin,

      In the current version, you need to run the stress recovery (-d) and failure analysis (-fi) separately. I can update the code to let the two analyses run in a single call of command in a future version.

      Reply Report abuse

      Replying to Su Tian

    5. Dana Frye

      I am able to run stress recovery and viz with my model, when the <element_type>linear</element_type>. However it doesn't appear to work when <element_type>quadratic</element_type>. Is this a known limitation or an issue on my end?

      Thanks, 

      Dana

      Cancel Report abuse

      Replying to Dana Frye

      1. Su Tian

        Dana,

        Thank you for reporting this issue. This has been fixed in the version 1.4.3.

        Report abuse